MOSFET驱动

[复制链接]
1195|33
 楼主 | 2019-3-12 16:17 | 显示全部楼层 |阅读模式
驱动芯片UCC27324D,驱动上下半桥的,第一次做硬件,我想试一下驱动电路好不好,
用的驱动芯片的典型应用原理图如下图,INA由DSP给3.3V的脉冲,我只测A路驱动的好坏。请前辈们指导,谢谢

问题:1判断驱动好坏是不是看mosfet的GS端波形幅值是不是12V左右,或者看输出OUTA的波形幅值是不是12V左右的方波(示波器接OUTA,探头地接芯片GND)

2.mosfet的
30V电源地是不是和三角形地不供地?

3.12-2.png



| 2019-3-12 16:29 | 显示全部楼层
关键在于,如果你用上图的电路去测,mos管会立马烧掉。
使用道具 评论回复
| 2019-3-12 18:14 | 显示全部楼层
你这是要看看到底是MOS管炸掉还是电源炸掉?
使用道具 评论回复
 楼主 | 2019-3-12 18:40 | 显示全部楼层
戈卫东 发表于 2019-3-12 18:14
你这是要看看到底是MOS管炸掉还是电源炸掉?

放了一个低级错误,那可不可以看输出OUTA的波形幅值是不是12V左右的方波(示波器接OUTA,探头地接芯片GND)来判断驱动电路好坏,不接mosfet和主电源
使用道具 评论回复
 楼主 | 2019-3-12 18:41 | 显示全部楼层
pleee 发表于 2019-3-12 16:29
关键在于,如果你用上图的电路去测,mos管会立马烧掉。

电路图画错了直通短路了,那请问如何判别驱动的一路A通道的好坏呢
使用道具 评论回复
| 2019-3-12 19:08 | 显示全部楼层
茫然闲 发表于 2019-3-12 18:40
放了一个低级错误,那可不可以看输出OUTA的波形幅值是不是12V左右的方波(示波器接OUTA,探头地接芯片GND ...

你这样测试看不出吗?反正手上有板子,不懂就看规格书,或自己做实验。碰到想不通的问题再来问,有利于提高自己。你自己不花点时间初步分析,大师更没时间看那么多无谓地规格书。
使用道具 评论回复
| 2019-3-12 20:39 | 显示全部楼层
2 必须共地。
使用道具 评论回复
| 2019-3-13 08:47 | 显示全部楼层
27324是非隔离驱动,所以输出输入必须共地。
至于测试线路,应该芯片部分没什么问题,关键是你测试的mos管怎么没带负载直接接30V呢?这样PWM一来,MOS管就烧了。
只是测试驱动,把MOS管漏极悬空吧,也省得再去找一个负载,这样就可以直接测试驱动波形了。
使用道具 评论回复
 楼主 | 2019-3-13 14:19 | 显示全部楼层
tianxj01 发表于 2019-3-13 08:47
27324是非隔离驱动,所以输出输入必须共地。
至于测试线路,应该芯片部分没什么问题,关键是你测试的mos管 ...

那MOSFET的地是和驱动芯片的地连一起吗?
使用道具 评论回复
 楼主 | 2019-3-13 15:17 | 显示全部楼层
本帖最后由 茫然闲 于 2019-3-13 15:24 编辑

使用发帖的电路图,这里没有接MOSFET,
驱动芯片供电12V,A通道的输入脉冲50KHZ,占空比45%,幅值3.3V,
测量了驱动芯片A通道的输出波形,输出的波形有问题,输入的脉冲占空比变化,outA的波形还是一样不变化,输入占空比45%,输出脉冲占空比只有0.9%,电压幅值12V左右,下图是INA脉冲占空比45%,频率50Khz,问题出在哪里?请大家指点,谢谢
3.13-1.jpg 3.13-2.jpg
3.13-2.jpg
使用道具 评论回复
| 2019-3-13 15:31 | 显示全部楼层
似乎你的输入信号根本就没有连到IC的管脚。。。
使用道具 评论回复
| 2019-3-13 15:57 | 显示全部楼层
茫然闲 发表于 2019-3-13 15:17
使用发帖的电路图,这里没有接MOSFET,驱动芯片供电12V,A通道的输入脉冲50KHZ,占空比45%,幅值3.3V,测量 ...

探枪没调整好?怎么没接MOS管振铃就这么严重,正常情况不可能,何况你还加了该有的退偶电容。
另外一路貌似就没有输出,只是振铃干扰一样的感觉。
仔细检查AB两路的PWM输入,一般这样芯片非常好用,接对了不会有什么问题。
使用道具 评论回复
 楼主 | 2019-3-13 16:00 | 显示全部楼层
戈卫东 发表于 2019-3-13 15:31
似乎你的输入信号根本就没有连到IC的管脚。。。

我是用的信号发生器(输出探头接芯片2号脚,地接芯片的地引脚),信号发生器出来有3.3V,50KHZ的方波给驱动芯片输入2脚如下图1,为什么一接驱动芯片2脚脉冲波就变成下图2波形。哪里有问题呢?
3.13.3.jpg 3.13-4.jpg

使用道具 评论回复
 楼主 | 2019-3-13 16:18 | 显示全部楼层
本帖最后由 茫然闲 于 2019-3-13 16:21 编辑
tianxj01 发表于 2019-3-13 15:57
探枪没调整好?怎么没接MOS管振铃就这么严重,正常情况不可能,何况你还加了该有的退偶电容。
另外一路貌 ...

你是说探头吗,探头没问题,出来的脉冲波挺好的,信号发生器发出的脉冲接到芯片的2脚即信号输入脚,脉冲波形就变成下图波形
3.13-4.jpg

使用道具 评论回复
| 2019-3-13 17:26 | 显示全部楼层
线断了,分布电容耦合。。。。
使用道具 评论回复
| 2019-3-13 17:31 | 显示全部楼层
茫然闲 发表于 2019-3-13 16:00
我是用的信号发生器(输出探头接芯片2号脚,地接芯片的地引脚),信号发生器出来有3.3V,50KHZ的方波给驱 ...

好像是很严重的微分波形,怀疑芯片已经受损,这个可能性比较大。
或者qy002千赢国际虚焊,示波器探枪因为阻抗高,看波形正常,接上芯片波形就变成微分波形。
使用道具 评论回复
 楼主 | 2019-3-13 18:26 | 显示全部楼层
戈卫东 发表于 2019-3-13 17:26
线断了,分布电容耦合。。。。

连接用的跳线,后面用的焊锡丝线框加粗焊接的,没有断路的情况
使用道具 评论回复
 楼主 | 2019-3-13 18:44 | 显示全部楼层
本帖最后由 茫然闲 于 2019-3-13 19:20 编辑
tianxj01 发表于 2019-3-13 17:31
好像是很严重的微分波形,怀疑芯片已经受损,这个可能性比较大。
或者qy002千赢国际虚焊,示波器探枪因为阻抗高 ...

换了一个芯片还是这样,只是幅值有点变化,没有虚焊,我焊了两个电路板,两个芯片输出端都是下图波形
用示波器测量信号发生器出来的是脉冲PWM波,为什么示波器的探头接INA,探头的地接芯片GND,为什么脉冲到INA就变了下图的波形呢


3.13-5.jpg

使用道具 评论回复
| 2019-3-14 07:12 | 显示全部楼层
茫然闲 发表于 2019-3-13 18:44
换了一个芯片还是这样,只是幅值有点变化,没有虚焊,我焊了两个电路板,两个芯片输出端都是下图波形。用 ...

检查接线有没有错,信号加的地方,测量的地方等有没有错。这是高通微分电路,中间肯定有电容耦合。你第一次做硬件,估计错误连篇,建议你把PCB,拍照出来,测试点标清楚。
使用道具 评论回复
| 2019-3-14 08:06 | 显示全部楼层
最简单的你找个面包板,找个MCU发方波,接个100R电阻到INC,给驱动芯片供好电,示波器看输出就可以了。另外一个电路图上一般单点接地
使用道具 评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册
本版积分规则
我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

关闭

热门推荐上一条 /5 下一条

快速回复 返回顶部 返回列表